Sunday, May 2, 2010

Installing Thunderbird addons in Ubuntu

Finally I found the time to write a new entry here. Searching for the topic I remembered that I tried to install the "Enigmail" addon for Thunderbird for a rather long time getting always the error message, that the downloaded version was not compatible with my Thunderbird version (fully updated 64bit version).


A few days ago I finally found the solution:

  • start Thunderbird as superuser: $ sudo thunderbird
  • install the plugin by using the addon-manager
  • after a restart of Thunderbird everything should be installed correctly
Of course this doesn't only apply to Enigmail, but also to all other plugins. However, if you still got the error message with Enigmail, try to download the current version from here and install it manually by using the "Install..." button located in the addon-manager window or simply drag'n'drop the downloaded *.xpi file into the (in sudo mode started) Thunderbird window.